aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..44cd5b6
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,13 @@
+project (smelt)
+
+cmake_minimum_required(VERSION 3.11)
+
+option (BUILD_DUMB "Disable sound support" OFF)
+option (BUILD_EXTENSIONS "Build extensions" ON)
+
+add_subdirectory(smelt/glfw)
+
+if (BUILD_EXTENSIONS)
+ add_subdirectory(extensions)
+endif ()
+