aboutsummaryrefslogtreecommitdiff
path: root/deduper/libpuzzle/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'deduper/libpuzzle/src/CMakeLists.txt')
-rw-r--r--deduper/libpuzzle/src/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/deduper/libpuzzle/src/CMakeLists.txt b/deduper/libpuzzle/src/CMakeLists.txt
new file mode 100644
index 0000000..634ef38
--- /dev/null
+++ b/deduper/libpuzzle/src/CMakeLists.txt
@@ -0,0 +1,21 @@
+project(puzzle C)
+
+include(FindPkgConfig)
+pkg_search_module(gdlib REQUIRED gdlib)
+
+add_library(puzzle STATIC
+ globals.h
+ puzzle_common.h
+ puzzle_p.h
+ puzzle.h
+ compress.c
+ cvec.c
+ dvec.c
+ puzzle.c
+ tunables.c
+ vector_ops.c
+)
+target_include_directories(puzzle
+ PRIVATE
+ ${gdlib_INCLUDE_DIRS}
+)