aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Gary Wang <wzc782970009@gmail.com> 2020-11-21 19:15:08 +0800
committerGravatar Chris Xiong <chirs241097@gmail.com> 2021-01-07 14:16:22 +0800
commit2716ffaf602fd9f39d9aca06a0853ed10cf90132 (patch)
treec70579c587e30a36980cc74218bff4dc33a4f808 /CMakeLists.txt
parentea68a817c1947b2001775d42755d260d66f4d37f (diff)
downloadQMidiPlayer-2716ffaf602fd9f39d9aca06a0853ed10cf90132.tar.xz
feat: windows extra plugin
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 8 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 32fc3c9..5862f0e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -16,7 +16,8 @@ pkg_search_module(rtmidi REQUIRED rtmidi)
option(BUILD_VISUALIZATION "Build visualization plugin" ON)
if(WIN32)
- option(BUILD_BACKTRACE "Build backtrace library" OFF)
+ option(BUILD_WINEXTRA "Build Windows extra library" ON)
+ option(BUILD_BACKTRACE "Build backtrace library" OFF)
endif()
if(UNIX)
option(BUILD_PORTABLE "Instruct the built binary not to search system directories" OFF)
@@ -37,7 +38,10 @@ if(BUILD_VISUALIZATION)
add_subdirectory(visualization)
endif()
if(WIN32)
-if(BUILD_BACKTRACE)
- add_subdirectory(third_party/backtrace-mingw)
-endif()
+ if(BUILD_WINEXTRA)
+ add_subdirectory(windows-extra)
+ endif()
+ if(BUILD_BACKTRACE)
+ add_subdirectory(third_party/backtrace-mingw)
+ endif()
endif()