aboutsummaryrefslogtreecommitdiff
path: root/windows-extra/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'windows-extra/CMakeLists.txt')
-rw-r--r--windows-extra/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/windows-extra/CMakeLists.txt b/windows-extra/CMakeLists.txt
new file mode 100644
index 0000000..6754e46
--- /dev/null
+++ b/windows-extra/CMakeLists.txt
@@ -0,0 +1,16 @@
+set(windowsextra_SOURCES
+ windowsextra.hpp
+ windowsextra.cpp
+)
+
+include_directories(${PROJECT_SOURCE_DIR}/include/)
+
+find_package(Qt5 REQUIRED COMPONENTS Widgets WinExtras)
+
+add_library(windowsextra MODULE
+ ${windowsextra_SOURCES}
+)
+
+target_link_libraries(windowsextra Qt5::Widgets Qt5::WinExtras)
+
+install(TARGETS windowsextra LIBRARY DESTINATION ${CMAKE_INSTALL_PREFIX}/lib/qmidiplayer/)