aboutsummaryrefslogtreecommitdiff
path: root/mpris-plugin/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Chris Xiong <chirs241097@gmail.com> 2023-11-26 01:10:36 -0500
committerGravatar Chris Xiong <chirs241097@gmail.com> 2023-11-26 01:10:36 -0500
commit60989e52b3f3bc0a95d3e61bd8e59fa4d9b7ab83 (patch)
treeaf08e5b6f7019c6f70bf3800a419ec78db140988 /mpris-plugin/CMakeLists.txt
parent382d85b15ce9cc4580a2522b39f5dd4ce43a24b0 (diff)
downloadQMidiPlayer-60989e52b3f3bc0a95d3e61bd8e59fa4d9b7ab83.tar.xz
The 2 year constipation. (mpris plugin)
Probably buggy as hell.
Diffstat (limited to 'mpris-plugin/CMakeLists.txt')
-rw-r--r--mpris-plugin/CMakeLists.txt30
1 files changed, 30 insertions, 0 deletions
diff --git a/mpris-plugin/CMakeLists.txt b/mpris-plugin/CMakeLists.txt
new file mode 100644
index 0000000..c0395c0
--- /dev/null
+++ b/mpris-plugin/CMakeLists.txt
@@ -0,0 +1,30 @@
+set(qmpmpris_SOURCES
+ qmpmpris.hpp
+ qmprisdbusinterface.hpp
+ qmpriswrapper.hpp
+ qmpmprisimpl.hpp
+ qmpmpris.cpp
+ qmprisdbusinterface.cpp
+ qmpriswrapper.cpp
+ qmpmprisimpl.cpp
+)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+find_package(Qt5 REQUIRED COMPONENTS DBus)
+
+include_directories(${PROJECT_SOURCE_DIR}/include/)
+
+add_library(qmpmpris MODULE
+ ${qmpmpris_SOURCES}
+)
+
+target_link_libraries(qmpmpris
+ Qt5::Core
+ Qt5::Widgets
+ Qt5::DBus
+)
+
+install(TARGETS qmpmpris LIBRARY DESTINATION ${CMAKE_INSTALL_PREFIX}/lib/qmidiplayer/)