aboutsummaryrefslogtreecommitdiff
path: root/windows-extra/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Gary Wang <wzc782970009@gmail.com> 2020-11-21 19:15:08 +0800
committerGravatar Chris Xiong <chirs241097@gmail.com> 2021-01-07 14:16:22 +0800
commit2716ffaf602fd9f39d9aca06a0853ed10cf90132 (patch)
treec70579c587e30a36980cc74218bff4dc33a4f808 /windows-extra/CMakeLists.txt
parentea68a817c1947b2001775d42755d260d66f4d37f (diff)
downloadQMidiPlayer-2716ffaf602fd9f39d9aca06a0853ed10cf90132.tar.xz
feat: windows extra plugin
Diffstat (limited to 'windows-extra/CMakeLists.txt')
-rw-r--r--windows-extra/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/windows-extra/CMakeLists.txt b/windows-extra/CMakeLists.txt
new file mode 100644
index 0000000..6754e46
--- /dev/null
+++ b/windows-extra/CMakeLists.txt
@@ -0,0 +1,16 @@
+set(windowsextra_SOURCES
+ windowsextra.hpp
+ windowsextra.cpp
+)
+
+include_directories(${PROJECT_SOURCE_DIR}/include/)
+
+find_package(Qt5 REQUIRED COMPONENTS Widgets WinExtras)
+
+add_library(windowsextra MODULE
+ ${windowsextra_SOURCES}
+)
+
+target_link_libraries(windowsextra Qt5::Widgets Qt5::WinExtras)
+
+install(TARGETS windowsextra LIBRARY DESTINATION ${CMAKE_INSTALL_PREFIX}/lib/qmidiplayer/)