aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6b92872..e789ec8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -9,7 +9,7 @@ set(CMAKE_CXX_STANDARD_REQUIRED ON)
set(CMAKE_CXX_EXTENSIONS OFF)
include(FindPkgConfig)
-find_package(Qt5 COMPONENTS Widgets REQUIRED)
+find_package(Qt5 REQUIRED COMPONENTS Widgets LinguistTools)
find_package(Threads REQUIRED)
pkg_search_module(fluidsynth REQUIRED fluidsynth>=2.0.0)
pkg_search_module(rtmidi REQUIRED rtmidi)
@@ -18,6 +18,9 @@ option(BUILD_VISUALIZATION "Build visualization plugin" ON)
if(WIN32)
option(BUILD_BACKTRACE "Build backtrace library" OFF)
endif()
+if(UNIX)
+ option(BUILD_PORTABLE "Instruct the built binary not to search system directories" OFF)
+endif()
add_subdirectory(core)
add_subdirectory(qmidiplayer-desktop)