aboutsummaryrefslogtreecommitdiff
path: root/windows-extra/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'windows-extra/CMakeLists.txt')
-rw-r--r--windows-extra/CMakeLists.txt4
1 files changed, 1 insertions, 3 deletions
diff --git a/windows-extra/CMakeLists.txt b/windows-extra/CMakeLists.txt
index 6754e46..c9b58ab 100644
--- a/windows-extra/CMakeLists.txt
+++ b/windows-extra/CMakeLists.txt
@@ -5,12 +5,10 @@ set(windowsextra_SOURCES
include_directories(${PROJECT_SOURCE_DIR}/include/)
-find_package(Qt5 REQUIRED COMPONENTS Widgets WinExtras)
-
add_library(windowsextra MODULE
${windowsextra_SOURCES}
)
-target_link_libraries(windowsextra Qt5::Widgets Qt5::WinExtras)
+target_link_libraries(windowsextra Qt${QT_VERSION_MAJOR}::Widgets Qt${QT_VERSION_MAJOR}::WinExtras)
install(TARGETS windowsextra LIBRARY DESTINATION ${CMAKE_INSTALL_PREFIX}/lib/qmidiplayer/)