aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Chris Xiong <chirs241097@gmail.com> 2022-09-11 10:27:54 -0400
committerGravatar Chris Xiong <chirs241097@gmail.com> 2022-09-11 10:27:54 -0400
commit609c17de008b7a6b817c7c12e214e7ef281d1178 (patch)
tree3d3f847a02d7d183f86c98f4b4f4657bb2b872a8 /CMakeLists.txt
parentc41768dbbd50a0055298d5ec6318ae7f1d2e4ab3 (diff)
downloaddeduper-609c17de008b7a6b817c7c12e214e7ef281d1178.tar.xz
Check actual size of type, not the platform.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5e32241..0c20a0d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,6 +7,14 @@ find_package(OpenCV REQUIRED COMPONENTS core imgproc imgcodecs highgui)
find_package(Threads REQUIRED)
include_directories(${OpenCV_INCLUDE_DIRS})
+INCLUDE (CheckTypeSize)
+
+SET(CMAKE_EXTRA_INCLUDE_FILES "filesystem")
+check_type_size("std::filesystem::path::value_type" PATH_VALSIZE LANGUAGE CXX)
+SET(CMAKE_EXTRA_INCLUDE_FILES)
+
+add_compile_definitions(PATH_VALSIZE=${PATH_VALSIZE})
+
include_directories(.)
add_library(xsig STATIC imageutil.cpp signature.cpp subslice_signature.cpp base64.cpp)