aboutsummaryrefslogtreecommitdiff
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Chris Xiong <chirs241097@gmail.com> 2022-09-18 01:52:26 -0400
committerGravatar Chris Xiong <chirs241097@gmail.com> 2022-09-18 01:52:26 -0400
commit4401f681d33f534a7d7ef8f4f940bd54b60710c3 (patch)
treed393f5fa9b5c7e96eae94e3986c40f9d80777818 /tests/CMakeLists.txt
parentf02cb7bf4978ec0fa1eea4ed0b21460b7637d741 (diff)
downloaddeduper-4401f681d33f534a7d7ef8f4f940bd54b60710c3.tar.xz
Move stuff around to accommodate new family members.
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt18
1 files changed, 3 insertions, 15 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 78ad4fe..fa76ab9 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -1,3 +1,6 @@
+get_target_property(xsig_priv_incdir xsig INCLUDE_DIRECTORIES)
+include_directories(compressed_vector ${xsig_priv_incdir})
+
add_executable(compressed_vector compressed_vector.cpp)
target_link_libraries(compressed_vector
xsig
@@ -20,18 +23,8 @@ target_link_libraries(image_util_tests
add_executable(signature_test signature_test.cpp)
target_link_libraries(signature_test
xsig
- opencv_core
- opencv_imgcodecs
- opencv_imgproc
)
-#add_executable(deduper_legacy deduper_legacy.cpp)
-#target_link_libraries(deduper_legacy
-# ${OpenCV_LIBS}
-# ${CMAKE_THREAD_LIBS_INIT}
-# xsig
-#)
-
add_executable(testdrive testdrive.cpp)
target_link_libraries(testdrive
xsig
@@ -47,11 +40,6 @@ endif()
add_executable(testdrive_sqlite testdrive_sqlite.cpp)
target_link_libraries(testdrive_sqlite
xsig
- opencv_core
- opencv_imgcodecs
- opencv_imgproc
- ${SQLite3_LIBRARIES}
- ${CMAKE_THREAD_LIBS_INIT}
)
if(WIN32)
target_link_libraries(testdrive_sqlite shell32 kernel32)