aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Chris Xiong <chirs241097@gmail.com> 2018-07-14 11:46:12 +0800
committerGravatar Chris Xiong <chirs241097@gmail.com> 2018-07-14 11:46:12 +0800
commitea652045bb38651d99bcc53972a524f602c3b306 (patch)
treeea7bf5f5b3f0a76faf07bfeb944b3a56f6afd527 /CMakeLists.txt
parente5aac499a8a2026af5d5176f45be3ac2576d75cc (diff)
downloadlightsd-ea652045bb38651d99bcc53972a524f602c3b306.tar.xz
Added a simple tool to create a fake sysfs backlight interface
that invokes external commands. Some changes in the utility module to accomodate the new tool. Added an option to watch ALS readings.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8b5e17e..f45cab6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2,9 +2,10 @@ cmake_minimum_required(VERSION 2.6)
project(lightsd)
set(SOURCES brightness_ctrl.cpp sensor_als.cpp sensors.cpp utils.cpp main.cpp)
set(CMAKE_CXX_STANDARD 17)
-set(CMAKE_CXX_STANDART_REQUIRED ON)
+set(CMAKE_CXX_STANDARD_REQUIRED ON)
find_package(Threads REQUIRED)
add_executable(${PROJECT_NAME} ${SOURCES})
+add_executable(fakebl tools/fakebl.c)
target_link_libraries(${PROJECT_NAME} stdc++fs)
target_link_libraries(${PROJECT_NAME} ${CMAKE_THREAD_LIBS_INIT})
install(TARGETS ${PROJECT_NAME} RUNTIME DESTINATION bin)