aboutsummaryrefslogtreecommitdiff
path: root/deduper/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Chris Xiong <chirs241097@gmail.com> 2020-04-06 00:50:58 +0800
committerGravatar Chris Xiong <chirs241097@gmail.com> 2020-04-06 00:50:58 +0800
commited47c1557915bb2472f6959e723cd76155312a98 (patch)
tree85bc451630ebaa4f5ffce3043b4cbf948a912a66 /deduper/CMakeLists.txt
parent0a094f28c2e2ebfaac91398ae62e40f00f09221b (diff)
downloadoddities-ed47c1557915bb2472f6959e723cd76155312a98.tar.xz
Add deduper (unfinished tool for finding image duplicates).
Diffstat (limited to 'deduper/CMakeLists.txt')
-rw-r--r--deduper/CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/deduper/CMakeLists.txt b/deduper/CMakeLists.txt
new file mode 100644
index 0000000..ac0859d
--- /dev/null
+++ b/deduper/CMakeLists.txt
@@ -0,0 +1,20 @@
+cmake_minimum_required(VERSION 3.11.0)
+project(deduper C CXX)
+set(CMAKE_CXX_STANDARD 17)
+set(CMAKE_CXX_STANDARD_REQUIRED ON)
+
+include(FindPkgConfig)
+pkg_search_module(gdlib REQUIRED gdlib)
+find_package(Threads REQUIRED)
+
+add_subdirectory(libpuzzle/src)
+add_executable(deduper deduper.cpp thread_pool.h)
+target_link_directories(deduper
+ PRIVATE
+ ${gdlib_LIBRARY_DIRS}
+)
+target_link_libraries(deduper
+ puzzle
+ ${gdlib_LIBRARIES}
+ ${CMAKE_THREAD_LIBS_INIT}
+)