summaryrefslogtreecommitdiff
path: root/app-misc/ledit/ledit-2.05.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/ledit/ledit-2.05.ebuild')
-rw-r--r--app-misc/ledit/ledit-2.05.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-misc/ledit/ledit-2.05.ebuild b/app-misc/ledit/ledit-2.05.ebuild
new file mode 100644
index 0000000..8d4c3a6
--- /dev/null
+++ b/app-misc/ledit/ledit-2.05.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A line editor to be used with interactive commands"
+HOMEPAGE="http://pauillac.inria.fr/~ddr/ledit/"
+SRC_URI="https://github.com/chetmurthy/ledit/archive/${P//\./-}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="+ocamlopt"
+
+RESTRICT="installsources !ocamlopt? ( strip )"
+
+DEPEND=">=dev-lang/ocaml-3.09:=[ocamlopt?]
+ dev-ml/camlp5:="
+RDEPEND="${DEPEND}"
+
+# For explanation please follow the link below.
+# https://github.com/gentoo/gentoo/pull/14865#issuecomment-605697524
+QA_FLAGS_IGNORED="/usr/bin/ledit"
+
+src_compile() {
+ emake -j1 all
+ if use ocamlopt; then
+ emake -j1 ledit.opt
+ fi
+}
+
+src_install() {
+ if use ocamlopt; then
+ newbin ledit.opt ledit
+ else
+ newbin ledit.out ledit
+ fi
+ doman ledit.1
+ dodoc CHANGES README
+}