aboutsummaryrefslogtreecommitdiff
path: root/qdeduper/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Chris Xiong <chirs241097@gmail.com> 2022-09-19 02:39:03 -0400
committerGravatar Chris Xiong <chirs241097@gmail.com> 2022-09-19 02:39:03 -0400
commit41e9051f2d809c42c3dfecc2eb11ad544cbd27b7 (patch)
treee370e08b0e0a45c6eef38704aa2f2b2b0e6d8033 /qdeduper/CMakeLists.txt
parent4b8d314f575d9e893d8dda7431194f8b470fc888 (diff)
downloaddeduper-41e9051f2d809c42c3dfecc2eb11ad544cbd27b7.tar.xz
You break it, you fix it!
The GUI is now working again, with scanning built-in.
Diffstat (limited to 'qdeduper/CMakeLists.txt')
-rw-r--r--qdeduper/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/qdeduper/CMakeLists.txt b/qdeduper/CMakeLists.txt
index f862c16..270cd45 100644
--- a/qdeduper/CMakeLists.txt
+++ b/qdeduper/CMakeLists.txt
@@ -1,6 +1,6 @@
set(CMAKE_INCLUDE_CURRENT_DIR ON)
-find_package(Qt5 REQUIRED COMPONENTS Widgets)
+find_package(Qt5 REQUIRED COMPONENTS Widgets Concurrent)
set(CMAKE_AUTOMOC ON)
set(CMAKE_AUTORCC ON)
@@ -10,9 +10,13 @@ add_executable(qdeduper
main.cpp
mingui.cpp
imageitem.cpp
+ sigdb_qt.cpp
+ filescanner.cpp
+ pathchooser.cpp
)
target_link_libraries(qdeduper
xsig
Qt5::Widgets
+ Qt5::Concurrent
)