aboutsummaryrefslogtreecommitdiff
path: root/qdeduper/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Chris Xiong <chirs241097@gmail.com> 2022-09-18 11:08:01 -0400
committerGravatar Chris Xiong <chirs241097@gmail.com> 2022-09-18 11:08:01 -0400
commit4b8d314f575d9e893d8dda7431194f8b470fc888 (patch)
tree4d42ebc06d2522c9141c42ff91be214e521e5fcb /qdeduper/CMakeLists.txt
parent0570b0f172631ba8f3c6180d2c850635c3cd6037 (diff)
downloaddeduper-4b8d314f575d9e893d8dda7431194f8b470fc888.tar.xz
First step to adopt mingui as part of the project -- break it!
Diffstat (limited to 'qdeduper/CMakeLists.txt')
-rw-r--r--qdeduper/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/qdeduper/CMakeLists.txt b/qdeduper/CMakeLists.txt
new file mode 100644
index 0000000..f862c16
--- /dev/null
+++ b/qdeduper/CMakeLists.txt
@@ -0,0 +1,18 @@
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+find_package(Qt5 REQUIRED COMPONENTS Widgets)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+add_executable(qdeduper
+ main.cpp
+ mingui.cpp
+ imageitem.cpp
+)
+
+target_link_libraries(qdeduper
+ xsig
+ Qt5::Widgets
+)