aboutsummaryrefslogtreecommitdiff
path: root/qdeduper/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'qdeduper/CMakeLists.txt')
-rw-r--r--qdeduper/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/qdeduper/CMakeLists.txt b/qdeduper/CMakeLists.txt
new file mode 100644
index 0000000..f862c16
--- /dev/null
+++ b/qdeduper/CMakeLists.txt
@@ -0,0 +1,18 @@
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+find_package(Qt5 REQUIRED COMPONENTS Widgets)
+
+set(CMAKE_AUTOMOC ON)
+set(CMAKE_AUTORCC ON)
+set(CMAKE_AUTOUIC ON)
+
+add_executable(qdeduper
+ main.cpp
+ mingui.cpp
+ imageitem.cpp
+)
+
+target_link_libraries(qdeduper
+ xsig
+ Qt5::Widgets
+)