aboutsummaryrefslogtreecommitdiff
path: root/deduper/libpuzzle/src/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Chris Xiong <chirs241097@gmail.com> 2020-04-06 00:50:58 +0800
committerGravatar Chris Xiong <chirs241097@gmail.com> 2020-04-06 00:50:58 +0800
commited47c1557915bb2472f6959e723cd76155312a98 (patch)
tree85bc451630ebaa4f5ffce3043b4cbf948a912a66 /deduper/libpuzzle/src/CMakeLists.txt
parent0a094f28c2e2ebfaac91398ae62e40f00f09221b (diff)
downloadoddities-ed47c1557915bb2472f6959e723cd76155312a98.tar.xz
Add deduper (unfinished tool for finding image duplicates).
Diffstat (limited to 'deduper/libpuzzle/src/CMakeLists.txt')
-rw-r--r--deduper/libpuzzle/src/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/deduper/libpuzzle/src/CMakeLists.txt b/deduper/libpuzzle/src/CMakeLists.txt
new file mode 100644
index 0000000..634ef38
--- /dev/null
+++ b/deduper/libpuzzle/src/CMakeLists.txt
@@ -0,0 +1,21 @@
+project(puzzle C)
+
+include(FindPkgConfig)
+pkg_search_module(gdlib REQUIRED gdlib)
+
+add_library(puzzle STATIC
+ globals.h
+ puzzle_common.h
+ puzzle_p.h
+ puzzle.h
+ compress.c
+ cvec.c
+ dvec.c
+ puzzle.c
+ tunables.c
+ vector_ops.c
+)
+target_include_directories(puzzle
+ PRIVATE
+ ${gdlib_INCLUDE_DIRS}
+)