summaryrefslogtreecommitdiff
path: root/app-benchmarks/s-tui/s-tui-1.1.4.ebuild
diff options
context:
space:
mode:
authorGravatar Chris Xiong <chirs241097@gmail.com> 2023-02-18 00:18:51 -0500
committerGravatar Chris Xiong <chirs241097@gmail.com> 2023-02-18 00:18:51 -0500
commitb14e71149683098eadde67ed842c58d0a2b64cd0 (patch)
tree3d187e72407a24a1ccb75f83938a762fa2247bc1 /app-benchmarks/s-tui/s-tui-1.1.4.ebuild
parent4fdb82a988ee7a939820f06e94aeefd3910c6c3c (diff)
downloadppo-b14e71149683098eadde67ed842c58d0a2b64cd0.tar.xz
s-tui: add 1.1.4.
Diffstat (limited to 'app-benchmarks/s-tui/s-tui-1.1.4.ebuild')
-rw-r--r--app-benchmarks/s-tui/s-tui-1.1.4.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-benchmarks/s-tui/s-tui-1.1.4.ebuild b/app-benchmarks/s-tui/s-tui-1.1.4.ebuild
new file mode 100644
index 0000000..d4fc98a
--- /dev/null
+++ b/app-benchmarks/s-tui/s-tui-1.1.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit eutils distutils-r1
+
+DESCRIPTION="Stress-Terminal UI monitoring tool"
+HOMEPAGE="https://amanusk.github.io/s-tui/"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/amanusk/${PN}.git"
+ EGIT_SUBMODULES=()
+else
+ # Pypi source doesn't include tests
+ SRC_URI="https://github.com/amanusk/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/urwid-2.0.1[${PYTHON_USEDEP}]
+ >=dev-python/psutil-5.6.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+
+pkg_postinst() {
+ elog "To get additional features, some optional runtime dependencies"
+ elog "may be installed:"
+ elog ""
+ optfeature "Stress options in program menu" app-benchmarks/stress
+}