summaryrefslogtreecommitdiff
path: root/dev-util/rust-analyzer/rust-analyzer-20220718.ebuild
diff options
context:
space:
mode:
authorGravatar Chris Xiong <chirs241097@gmail.com> 2022-07-20 12:18:41 -0400
committerGravatar Chris Xiong <chirs241097@gmail.com> 2022-07-20 12:18:41 -0400
commit55cc2e0a638b007120048f5f5616e2771e2d4293 (patch)
tree132cc4d780da51cc3d87f66aa62dae5e88ba2d55 /dev-util/rust-analyzer/rust-analyzer-20220718.ebuild
parentbb6b36eba4b6aaf79465fc894b51f11ed5c0852b (diff)
downloadppo-55cc2e0a638b007120048f5f5616e2771e2d4293.tar.xz
one day it will work, right?
Diffstat (limited to 'dev-util/rust-analyzer/rust-analyzer-20220718.ebuild')
-rw-r--r--dev-util/rust-analyzer/rust-analyzer-20220718.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-util/rust-analyzer/rust-analyzer-20220718.ebuild b/dev-util/rust-analyzer/rust-analyzer-20220718.ebuild
index c6313bc..481307b 100644
--- a/dev-util/rust-analyzer/rust-analyzer-20220718.ebuild
+++ b/dev-util/rust-analyzer/rust-analyzer-20220718.ebuild
@@ -14,7 +14,7 @@ else
KEYWORDS="~amd64"
EGIT_COMMIT="${PV:0:4}-${PV:4:2}-${PV:6:2}"
EGIT_REPO_URI="https://github.com/rust-analyzer/rust-analyzer"
- SRC_URI="https://github.com/rust-analyzer/rust-analyzer/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz $(cargo_crate_uris)"
+ SRC_URI="https://github.com/rust-analyzer/rust-analyzer/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz $(cargox_crate_uris)"
fi
DESCRIPTION="An implementation of Language Server Protocol for the Rust programming language"
@@ -32,14 +32,14 @@ QA_FLAGS_IGNORED="usr/bin/rust-analyzer"
src_unpack() {
git-r3_src_unpack
- cargo_live_src_unpack
+ cargox_live_src_unpack
}
src_test() {
# Requires out of source git repo.
- cargo_src_test -- --skip "tidy::check_merge_commits"
+ cargox_src_test -- --skip "tidy::check_merge_commits"
}
src_install() {
- cargo_src_install --path "./crates/rust-analyzer"
+ cargox_src_install --path "./crates/rust-analyzer"
}