summaryrefslogtreecommitdiff
path: root/dev-util/rust-analyzer/rust-analyzer-20220718.ebuild
diff options
context:
space:
mode:
authorGravatar Chris Xiong <chirs241097@gmail.com> 2022-12-15 11:33:11 -0500
committerGravatar Chris Xiong <chirs241097@gmail.com> 2022-12-15 11:33:11 -0500
commit87164d0194c700690e1f3d02f6245d1a010a1a6d (patch)
treeac08959156b6af8969936b28e23a635a4823de71 /dev-util/rust-analyzer/rust-analyzer-20220718.ebuild
parent4bd74f8d8a1edfaaa25bc82c9fc76ddc8f97baee (diff)
downloadppo-87164d0194c700690e1f3d02f6245d1a010a1a6d.tar.xz
dev-util/rust-analyzer: treeclean
Diffstat (limited to 'dev-util/rust-analyzer/rust-analyzer-20220718.ebuild')
-rw-r--r--dev-util/rust-analyzer/rust-analyzer-20220718.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/dev-util/rust-analyzer/rust-analyzer-20220718.ebuild b/dev-util/rust-analyzer/rust-analyzer-20220718.ebuild
deleted file mode 100644
index 481307b..0000000
--- a/dev-util/rust-analyzer/rust-analyzer-20220718.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 2020-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-CRATES="
-"
-
-inherit cargox git-r3
-
-if [[ "${PV}" == *9999* ]]; then
- EGIT_REPO_URI="https://github.com/rust-analyzer/rust-analyzer"
-else
- KEYWORDS="~amd64"
- EGIT_COMMIT="${PV:0:4}-${PV:4:2}-${PV:6:2}"
- EGIT_REPO_URI="https://github.com/rust-analyzer/rust-analyzer"
- SRC_URI="https://github.com/rust-analyzer/rust-analyzer/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz $(cargox_crate_uris)"
-fi
-
-DESCRIPTION="An implementation of Language Server Protocol for the Rust programming language"
-HOMEPAGE="https://rust-analyzer.github.io"
-
-LICENSE="0BSD Apache-2.0 Artistic-2 BSD Boost-1.0 CC0-1.0 ISC MIT Unlicense ZLIB"
-RESTRICT="mirror"
-SLOT="live"
-IUSE=""
-
-DEPEND="|| ( >=dev-lang/rust-1.57.0[rust-src] >=dev-lang/rust-bin-1.57.0[rust-src] )"
-RDEPEND="${DEPEND}"
-
-QA_FLAGS_IGNORED="usr/bin/rust-analyzer"
-
-src_unpack() {
- git-r3_src_unpack
- cargox_live_src_unpack
-}
-
-src_test() {
- # Requires out of source git repo.
- cargox_src_test -- --skip "tidy::check_merge_commits"
-}
-
-src_install() {
- cargox_src_install --path "./crates/rust-analyzer"
-}