summaryrefslogtreecommitdiff
path: root/net-libs/libquotient/libquotient-0.6.99.ebuild
diff options
context:
space:
mode:
authorGravatar Chris Xiong <chirs241097@gmail.com> 2022-12-15 11:32:46 -0500
committerGravatar Chris Xiong <chirs241097@gmail.com> 2022-12-15 11:32:46 -0500
commit4bd74f8d8a1edfaaa25bc82c9fc76ddc8f97baee (patch)
treef039b65de0e87d205c9f80d42027b995baedf670 /net-libs/libquotient/libquotient-0.6.99.ebuild
parent050772be1105b258beb6b657d70fcfe86cebb06c (diff)
downloadppo-4bd74f8d8a1edfaaa25bc82c9fc76ddc8f97baee.tar.xz
net-libs/libquotient: new package, add 0.6.99
Diffstat (limited to 'net-libs/libquotient/libquotient-0.6.99.ebuild')
-rw-r--r--net-libs/libquotient/libquotient-0.6.99.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-libs/libquotient/libquotient-0.6.99.ebuild b/net-libs/libquotient/libquotient-0.6.99.ebuild
new file mode 100644
index 0000000..025431e
--- /dev/null
+++ b/net-libs/libquotient/libquotient-0.6.99.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Qt5-based SDK to develop applications for Matrix"
+HOMEPAGE="https://github.com/quotient-im/libQuotient"
+SRC_URI="https://github.com/quotient-im/libQuotient/archive/0.7-rc.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/libQuotient-0.7-rc"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64"
+IUSE=""
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtnetwork:5[ssl]
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ # downstream patches
+ "${FILESDIR}"/${PN}-0.7-no-android.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DQuotient_INSTALL_TESTS=OFF
+ -DQuotient_ENABLE_E2EE=OFF # TODO: libolm, libqtolm not packaged
+ -DCMAKE_DISABLE_FIND_PACKAGE_Git=ON # no thanks.
+ )
+ cmake_src_configure
+}