summaryrefslogtreecommitdiff
path: root/sys-process/nvtop/nvtop-3.1.0.ebuild
diff options
context:
space:
mode:
authorGravatar Chris Xiong <chirs241097@gmail.com> 2024-05-03 21:38:59 -0400
committerGravatar Chris Xiong <chirs241097@gmail.com> 2024-05-03 21:38:59 -0400
commit9f4f78066ab597f969ad6223aa6a7845bb4753d7 (patch)
tree0518010079fc39db55fe4f562dbea09b2a818142 /sys-process/nvtop/nvtop-3.1.0.ebuild
parentef08b3b5fa91b32161264c071fc3a0c48d51af0d (diff)
downloadppo-9f4f78066ab597f969ad6223aa6a7845bb4753d7.tar.xz
nvtop 3.1.0.
Diffstat (limited to 'sys-process/nvtop/nvtop-3.1.0.ebuild')
-rw-r--r--sys-process/nvtop/nvtop-3.1.0.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/sys-process/nvtop/nvtop-3.1.0.ebuild b/sys-process/nvtop/nvtop-3.1.0.ebuild
new file mode 100644
index 0000000..5c2c509
--- /dev/null
+++ b/sys-process/nvtop/nvtop-3.1.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg
+
+DESCRIPTION="NVIDIA GPUs htop like monitoring tool"
+HOMEPAGE="https://github.com/Syllo/nvtop"
+
+if [[ "${PV}" == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/Syllo/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/Syllo/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+IUSE="unicode video_cards_intel video_cards_amdgpu video_cards_nvidia"
+
+RDEPEND="
+ video_cards_intel? ( virtual/udev )
+ video_cards_amdgpu? ( x11-libs/libdrm[video_cards_amdgpu] )
+ video_cards_nvidia? ( x11-drivers/nvidia-drivers )
+ sys-libs/ncurses:0=
+"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr"
+ -DCURSES_NEED_WIDE=$(usex unicode)
+ -DINTEL_SUPPORT=$(usex video_cards_intel)
+ -DNVIDIA_SUPPORT=$(usex video_cards_nvidia)
+ -DAMDGPU_SUPPORT=$(usex video_cards_amdgpu)
+ )
+
+ cmake_src_configure
+} \ No newline at end of file