summaryrefslogtreecommitdiff
path: root/app-benchmarks/s-tui/s-tui-1.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-benchmarks/s-tui/s-tui-1.0.0.ebuild')
-rw-r--r--app-benchmarks/s-tui/s-tui-1.0.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-benchmarks/s-tui/s-tui-1.0.0.ebuild b/app-benchmarks/s-tui/s-tui-1.0.0.ebuild
new file mode 100644
index 0000000..005cb68
--- /dev/null
+++ b/app-benchmarks/s-tui/s-tui-1.0.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Stress-Terminal UI monitoring tool"
+HOMEPAGE="https://amanusk.github.io/s-tui/"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/amanusk/s-tui"
+else
+ SRC_URI="https://github.com/amanusk/s-tui/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+stress"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ >=dev-python/urwid-2.0.1[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ stress? ( app-benchmarks/stress )"