summaryrefslogtreecommitdiff
path: root/dev-cpp/pystring/pystring-1.1.3-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/pystring/pystring-1.1.3-r1.ebuild')
-rw-r--r--dev-cpp/pystring/pystring-1.1.3-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-cpp/pystring/pystring-1.1.3-r1.ebuild b/dev-cpp/pystring/pystring-1.1.3-r1.ebuild
new file mode 100644
index 0000000..7694add
--- /dev/null
+++ b/dev-cpp/pystring/pystring-1.1.3-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="C++ functions matching the interface and behavior of python string methods"
+HOMEPAGE="https://github.com/imageworks/pystring"
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/imageworks/pystring.git"
+else
+ SRC_URI="https://github.com/imageworks/pystring/archive/v"${PV}".tar.gz -> "${P}".tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+BDEPEND="
+ virtual/libc
+ sys-devel/libtool
+"
+RESTRICT="mirror"
+
+LICENSE="BSD"
+SLOT="0"
+
+src_compile() {
+ sed -i -e "s|-O3|${CXXFLAGS}|g" Makefile || die
+ emake LIBDIR="${S}" install
+ #Fix header location
+ mkdir ${S}/pystring || die
+ mv ${S}/pystring.h ${S}/pystring || die
+}
+
+src_install() {
+ dolib.so ${S}/libpystring.so{,.0{,.0.0}}
+ doheader -r ${S}/pystring
+}