summaryrefslogtreecommitdiff
path: root/dev-util/rust-analyzer/rust-analyzer-20220718.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/rust-analyzer/rust-analyzer-20220718.ebuild')
-rw-r--r--dev-util/rust-analyzer/rust-analyzer-20220718.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-util/rust-analyzer/rust-analyzer-20220718.ebuild b/dev-util/rust-analyzer/rust-analyzer-20220718.ebuild
index 0bdf488..1e3443f 100644
--- a/dev-util/rust-analyzer/rust-analyzer-20220718.ebuild
+++ b/dev-util/rust-analyzer/rust-analyzer-20220718.ebuild
@@ -12,9 +12,9 @@ if [[ "${PV}" == *9999* ]]; then
EGIT_REPO_URI="https://github.com/rust-analyzer/rust-analyzer"
else
KEYWORDS="~amd64"
- MY_PV="${PV:0:4}-${PV:4:2}-${PV:6:2}"
+ EGIT_COMMIT="${PV:0:4}-${PV:4:2}-${PV:6:2}"
EGIT_REPO_URI="https://github.com/rust-analyzer/rust-analyzer"
- EGIT_COMMIT="${MY_PV}"
+ SRC_URI="https://github.com/rust-analyzer/rust-analyzer/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz $(cargo_crate_uris)"
fi
DESCRIPTION="An implementation of Language Server Protocol for the Rust programming language"