summaryrefslogtreecommitdiff
path: root/dev-util/rust-analyzer/rust-analyzer-20220718.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/rust-analyzer/rust-analyzer-20220718.ebuild')
-rw-r--r--dev-util/rust-analyzer/rust-analyzer-20220718.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-util/rust-analyzer/rust-analyzer-20220718.ebuild b/dev-util/rust-analyzer/rust-analyzer-20220718.ebuild
index 6764dd8..603a4ce 100644
--- a/dev-util/rust-analyzer/rust-analyzer-20220718.ebuild
+++ b/dev-util/rust-analyzer/rust-analyzer-20220718.ebuild
@@ -13,8 +13,10 @@ if [[ "${PV}" == *9999* ]]; then
EGIT_REPO_URI="https://github.com/rust-analyzer/rust-analyzer"
else
KEYWORDS="~amd64"
+ inherit git-r3
MY_PV="${PV:0:4}-${PV:4:2}-${PV:6:2}"
- SRC_URI="https://github.com/rust-analyzer/rust-analyzer/archive/${MY_PV}.tar.gz -> ${P}.tar.gz $(cargo_crate_uris)"
+ EGIT_REPO_URI="https://github.com/rust-analyzer/rust-analyzer"
+ EGIT_COMMIT="${MY_PV}"
fi
DESCRIPTION="An implementation of Language Server Protocol for the Rust programming language"
@@ -47,4 +49,4 @@ src_test() {
src_install() {
cargo_src_install --path "./crates/rust-analyzer"
-} \ No newline at end of file
+}