summaryrefslogtreecommitdiff
path: root/sys-auth/fprintd/fprintd-1.94.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth/fprintd/fprintd-1.94.0.ebuild')
-rw-r--r--sys-auth/fprintd/fprintd-1.94.0.ebuild81
1 files changed, 0 insertions, 81 deletions
diff --git a/sys-auth/fprintd/fprintd-1.94.0.ebuild b/sys-auth/fprintd/fprintd-1.94.0.ebuild
deleted file mode 100644
index c4cc4c0..0000000
--- a/sys-auth/fprintd/fprintd-1.94.0.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} )
-inherit meson pam python-single-r1 systemd
-
-DESCRIPTION="D-Bus service to access fingerprint readers"
-HOMEPAGE="https://cgit.freedesktop.org/libfprint/fprintd/"
-SHA="fc7e058e937db861d1868a55b5316798d14fe0b7"
-SRC_URI="https://gitlab.freedesktop.org/libfprint/fprintd/-/archive/v${PV}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="gtk-doc +pam static-libs systemd test"
-REQUIRED_USE="systemd? ( pam )
- test? ( ${PYTHON_REQUIRED_USE} )"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-libs/dbus-glib
- dev-libs/glib:2
- >=sys-auth/libfprint-${PV}
- sys-auth/polkit
- systemd? ( sys-apps/systemd )
- pam? (
- systemd? ( sys-apps/systemd )
- !systemd? ( sys-auth/elogind )
- sys-libs/pam
- )"
-DEPEND="${RDEPEND}
- dev-util/intltool
- gtk-doc? (
- dev-util/gtk-doc
- dev-util/gtk-doc-am
- dev-libs/libxml2
- )"
-BDEPEND="test? (
- dev-python/python-dbusmock
- pam? ( sys-libs/pam_wrapper )
- )"
-
-PATCHES=(
- "${FILESDIR}/${PN}-1.90.7_0001-add-test-feature-and-make-tests-optional.patch"
- "${FILESDIR}/${PN}-1.90.8_0002-add-configure-option-for-libsystemd-provider.patch"
-)
-
-S="${WORKDIR}/${PN}-v${PV}-${SHA}"
-
-DOCS=( pam/README )
-
-src_configure() {
- local emesonargs=(
- $(meson_feature test)
- $(meson_use pam)
- -Dsystemd_system_unit_dir=$(systemd_get_systemunitdir)
- -Dman=true
- -Dgtk_doc=$(usex gtk-doc true false)
- -Dpam_modules_dir=$(getpam_mod_dir)
- -Dlibsystemd=$(usex systemd libsystemd libelogind)
- )
- meson_src_configure
-}
-
-src_install() {
- meson_src_install
- keepdir /var/lib/fprint
- find "${D}" -name "*.la" -delete || die
- einstalldocs
- if use gtk-doc; then
- insinto /usr/share/doc/${PF}/html
- doins doc/{fprintd-docs,version}.xml
- insinto /usr/share/doc/${PF}/html/dbus
- doins doc/dbus/net.reactivated.Fprint.{Device,Manager}.ref.xml
- fi
-}
-
-pkg_postinst() {
- elog "Please take a look at README.pam_fprintd for integration docs."
-}