summaryrefslogtreecommitdiff
path: root/x11-libs/xcb-imdkit/xcb-imdkit-1.0.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/xcb-imdkit/xcb-imdkit-1.0.3.ebuild')
-rw-r--r--x11-libs/xcb-imdkit/xcb-imdkit-1.0.3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/x11-libs/xcb-imdkit/xcb-imdkit-1.0.3.ebuild b/x11-libs/xcb-imdkit/xcb-imdkit-1.0.3.ebuild
new file mode 100644
index 0000000..71c9f99
--- /dev/null
+++ b/x11-libs/xcb-imdkit/xcb-imdkit-1.0.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Input method development support for xcb"
+HOMEPAGE="https://github.com/fcitx/xcb-imdkit"
+SRC_URI="https://github.com/fcitx/xcb-imdkit/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="
+ MIT
+ LGPL-2.1+
+ !system-uthash? ( BSD-1 )
+"
+SLOT="5"
+KEYWORDS="~amd64 ~x86"
+IUSE="+system-uthash"
+
+RDEPEND="
+ x11-libs/libxcb
+ x11-libs/xcb-util
+ x11-libs/xcb-util-keysyms
+"
+DEPEND="
+ ${RDEPEND}
+ kde-frameworks/extra-cmake-modules:5
+ system-uthash? ( dev-libs/uthash )
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_SYSTEM_UTHASH=$(usex system-uthash ON OFF)
+ )
+ cmake_src_configure
+} \ No newline at end of file