aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Gary Wang <wzc782970009@gmail.com> 2019-06-15 15:21:32 +0800
committerGravatar Chris Xiong <chirs241097@gmail.com> 2019-06-15 20:58:10 +0800
commit591c44b9a1a6e0a803b6d8af9e35aa8552b421c0 (patch)
tree8d422a4888c4371b0960bcdd5665d99b6f43b27a /CMakeLists.txt
parent747c0db7910414d2797e38b5a00efbdb0c5ee6a1 (diff)
downloadSMELT-591c44b9a1a6e0a803b6d8af9e35aa8552b421c0.tar.xz
DevIL support
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 44cd5b6..6b54346 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -4,6 +4,8 @@ cmake_minimum_required(VERSION 3.11)
option (BUILD_DUMB "Disable sound support" OFF)
option (BUILD_EXTENSIONS "Build extensions" ON)
+option (USE_CXIMAGE "Use CxImage instead of DevIL" OFF)
+option (BUILD_EXAMPLE "Build example" ON)
add_subdirectory(smelt/glfw)
@@ -11,3 +13,6 @@ if (BUILD_EXTENSIONS)
add_subdirectory(extensions)
endif ()
+if (BUILD_EXAMPLE)
+ add_subdirectory(examples)
+endif ()