aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Gary Wang <wzc782970009@gmail.com> 2019-06-02 01:22:18 +0800
committerGravatar Chris Xiong <chirs241097@gmail.com> 2019-06-15 20:58:10 +0800
commit747c0db7910414d2797e38b5a00efbdb0c5ee6a1 (patch)
treef003595d63aa2f5b7191e4587bc770f99d760c3a /CMakeLists.txt
parent2da6a4aec9a249417a9e4c0106ab6bec0489a36f (diff)
downloadSMELT-747c0db7910414d2797e38b5a00efbdb0c5ee6a1.tar.xz
Basic CMake support
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..44cd5b6
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,13 @@
+project (smelt)
+
+cmake_minimum_required(VERSION 3.11)
+
+option (BUILD_DUMB "Disable sound support" OFF)
+option (BUILD_EXTENSIONS "Build extensions" ON)
+
+add_subdirectory(smelt/glfw)
+
+if (BUILD_EXTENSIONS)
+ add_subdirectory(extensions)
+endif ()
+