aboutsummaryrefslogtreecommitdiff
path: root/smelt/glfw/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Chris Xiong <chirs241097@gmail.com> 2019-09-13 00:41:03 +0800
committerGravatar Chris Xiong <chirs241097@gmail.com> 2019-09-13 00:41:03 +0800
commit2836b3d1bdb32765950b8e3133a2452d8e7b98d2 (patch)
tree36109a163491ceb9abec4e39a2944509ca9466e7 /smelt/glfw/CMakeLists.txt
parentf5cd05e88b4068550b8ec244541c95050b1e6a5e (diff)
downloadSMELT-2836b3d1bdb32765950b8e3133a2452d8e7b98d2.tar.xz
cmake: generate position independent code, add missing include dirs.
Diffstat (limited to 'smelt/glfw/CMakeLists.txt')
-rw-r--r--smelt/glfw/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/smelt/glfw/CMakeLists.txt b/smelt/glfw/CMakeLists.txt
index 73c2130..10a4120 100644
--- a/smelt/glfw/CMakeLists.txt
+++ b/smelt/glfw/CMakeLists.txt
@@ -16,6 +16,8 @@ set (SMELT_GLFW_CPP_FILES
sys_glfw.cpp
)
+set(CMAKE_POSITION_INDEPENDENT_CODE ON)
+
include_directories(
${GLEW_INCLUDE_DIRS}
)